Call us on 02392 006118 for sales & support

Search on Knowledge Base
Lithe Audio: What version of Bluetooth are the speakers compatible with?
7 Dec 2016 by Craig Walker

Bluetooth Version 4.0 and above shall all work with ceiling speakers.

Please check device has bluetooth, as some device need this setup to function.

Back to top